debiancdn

AWS, Content Delivery Network and Debian

日別アーカイブ: 2008/04/10

rails1.1.6から2.0.2への移行をひきうけることに.

なんというかだいぶ前に1.1.6で書かれたプログラムを2.0系で動くようにする話に口を出してしまったのでやることに.

とりあえず1.1.6->1.2.6->2.0.2でやろうかなあ,という気もするが面倒なのできっといきなり2.0.2にしてしまうな.

Riding Rails: Rails 2.0: It’s done!

So how do I upgrade?

If you want to move your application to Rails 2.0, you should first move it to Rails 1.2.6. That’ll include deprecation warnings for most everything we yanked out in 2.0. So if your application runs fine on 1.2.6 with no deprecation warnings, there’s a good chance that it’ll run straight up on 2.0. Of course, if you’re using, say, pagination, you’ll need to install the classic_pagination plugin. If you’re using Oracle, you’ll need to install the activerecord-oracle-adapter gem. And so on and so forth for all the extractions.