debiancdn

AWS, Content Delivery Network and Debian

日別アーカイブ: 2009/04/08

sidでrubygems1.8のdebつかうのやめた

現在のsidではrubygems1.8が1.2.0-3なので,どうにもgemsの今のversionである1.3からみると遅いので,rubygemsをdebつかうのをやめてみる.なにしろ railsコマンドやったら古いぞふざけんなと出たので..

前提

  • PATHに/var/lib/gems/1.8/binが今はいっている.
  • rubygemsがdebではいっている.
  • そのgemsでいれたパッケージもけっこうある
/var/lib/gems/1.8/gems$ ls
actionmailer-2.0.2/                hpricot-0.6/          rails-2.0.2/
actionpack-2.0.2/                  libxml-ruby-0.5.4/    railscheck-0.2.0/
activerecord-2.0.2/                libxml-xmlrpc-0.1.4/  rake-0.8.1/
activeresource-2.0.2/              mocha-0.5.6/          rfacebook-0.9.8/
activesupport-2.0.2/               mysql-2.7/            w3c_validators-0.9.3/
has_many_through_generator-0.4.0/  packet-0.1.5/         will_paginate-2.2.2/

手順

 sudo apt-get remove rubygems rubygems1.8
 $ gem -v
 -bash: /usr/bin/gem: そのようなファイルやディレクトリはありません

rubyforgeからとってきてruby setup.rb.

とりあえずこれで使えてる.